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1. Overview 

The Canadian Wildland Fire Information System (CWFIS 2.0) provides national wildland fire information 

through open geospatial web services and downloadable datasets. Most of the information, data and 

map layers available on the CWFIS website are served via OGC‑compliant services hosted on the CWFIS 

GeoServer platform: 

• WMS — Web Map Service (rendered map images) 

• WFS — Web Feature Service (vector features & attributes) 

• WCS — Web Coverage Service (raster coverages) 

These services can be used in GIS applications (QGIS, ArcGIS, etc.), web applications, and automated 

workflows. 

2. CWFIS 2.0 Resources 

CWFIS map layers, data products and services can be viewed and accessed from the following resources: 

• CWFIS 2.0 Home: The CWFIS landing page provides an overview of current conditions and a portal 

into all other content available 

• Interactive Map: Allows users to view, explore and access many of the CWFIS data layers through an 

online mapping interface 

• Static Map Viewer: Provides static map images representing most of the CWFIS data layers for quick 

viewing, reference and comparison 

• National Wildland Fire Summary: Provides static map images and fire statistics summarizing 

current wildland fire conditions 

• Forecast Conditions: Maps displaying short- and long-term wildland fire conditions as well as 

monthly forecasts 

• Fire History Data Explorer: Provides fire history maps and statistics derived from national fire 

history data products 

• Data Catalogue: Provides detailed information on all public data products and services available through 

the CWFIS 

• Downloads Directory: Contains a collection of core datasets and resources available as 

downloadable files 

• Data Services Placemat: Offers a summary of key map layers delivered as public CWFIS services, 

along with information on recent changes and updates. 

https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/interactive-map/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/static-maps/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/summary/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/forecast
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/fire-history/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/data-catalog
https://cwfis.cfs.nrcan.gc.ca/downloads/
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3. Downloadable Core Datasets 

A set of core datasets and resources are available as downloadable files from the CWFIS 2.0 Downloads 

Directory. Here is a list of some of the most requested datasets: 

• Current active fires (reported by agencies) 

• Current satellite‑detected hotspots (CSV or SHP) 

• Current fire perimeter estimates (derived from satellite hotspots) 

• Current national CFFDRS grids (FWI/FBP) 

• Current fire danger (using agency classifications) 

• Current fire weather observations at station locations 

• National Fire Database and summary statistics 

• National Burned Area Composite and summary statistics 

• Canadian Wildland Fire Evacuation Database summary statistics 

 

Note: Most of the downloadable files in the CWFIS Downloads Directory are generated from the same data 

sources as served through the CWFIS GeoServer data services described below. However, some of the 

downloadable files are produced through other processing workflows. As a result, the information contained 

may differ slightly from the GeoServer services due to processing schedules or update times. 

 

To explore the full set of available data products, refer to the CWFIS Data Services Placemat and/or the 

CWFIS Data Catalogue. Guidance on how to access and connect to these GeoServer services is provided 

later in this resource. 

 

4. CWFIS GeoServer Data Services 

Most CWFIS 2.0 data layers, including those shown in all CWFIS map products, are served through CWFIS 

GeoServer using OGC web services.  

Base GeoServer Endpoints  

Note: CWFIS currently uses two GeoServer instances to provide data services—our legacy CWFIS GeoServer 

and the newer Canadian Wildland Fire Information Framework (CWFIF) GeoServer. All services will be 

migrated to the new CWFIF GeoServer to ensure a unified, single service endpoint. 

https://cwfis.cfs.nrcan.gc.ca/downloads/
https://cwfis.cfs.nrcan.gc.ca/downloads/
https://cwfis.cfs.nrcan.gc.ca/downloads/activefires/
https://cwfis.cfs.nrcan.gc.ca/downloads/hotspots/
https://cwfis.cfs.nrcan.gc.ca/downloads/hotspots/
https://cwfis.cfs.nrcan.gc.ca/downloads/cffdrs/
https://cwfis.cfs.nrcan.gc.ca/downloads/fire_danger/
https://cwfis.cfs.nrcan.gc.ca/downloads/fwi_obs/current/
https://cwfis.cfs.nrcan.gc.ca/downloads/nfdb/fire_pnt/current_version/
https://cwfis.cfs.nrcan.gc.ca/downloads/nbac/
https://cwfis.cfs.nrcan.gc.ca/downloads/evacs/
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/data-catalog
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WMS (Web Map Service) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wms? 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/wms? 

  

WFS (Web Feature Service) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs? 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs? 

  

WCS (Web Coverage Service) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs? 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/wcs? 

  

5. GetCapabilities Requests 

To view the list of map layers available from the CWFIS GeoServer, use the GeoServer OWS endpoint with a 

GetCapabilities request. This request returns all layers offered through the WMS, WFS, and WCS services. 

Note: CWFIS currently uses two GeoServer instances to provide data services—our legacy CWFIS GeoServer 

and the newer Canadian Wildland Fire Information Framework (CWFIF) GeoServer. All services will be 

migrated to the new CWFIF GeoServer to ensure a unified, single service endpoint. 

WMS — GetCapabilities 

Lists layers available as map images (pixel-based). 

https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=GetCapabi

lities 

 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=Get

Capabilities 

  

WFS — GetCapabilities 

Lists layers available as feature types (vector data with geometry and attributes). 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wms
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wms
https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wcs
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=GetCapabilities
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WMS&version=1.3.0&request=GetCapabilities
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https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetCapabi

lities 

 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=Get

Capabilities 

  

WCS — GetCapabilities 

Lists layers available as coverages (raster data) 
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=GetCapabi

lities 

 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=Get

Capabilities 

 

6. Data Access Formats 

• WMS → rendered map images (PNG, JPEG, GIF, KMZ, GeoTIFF, PDF, OpenLayers output) 

• WFS → vector data (CSV, GeoJSON, GML, SHAPE‑ZIP, KML) 

• WCS → raster data (GeoTIFF, ArcGrid, GTopo30, compressed formats) 

Users can connect these endpoints directly in GIS tools such as QGIS, ArcGIS Pro, or web mapping clients. 

7. WMS — GetMap Requests 

Retrieve map images by specifying a WMS layer and bounding box. 

WMS format options: PNG, JPEG, GIF, KMZ, GeoTIFF, PDF, OpenLayers output 

Example: Last 24‑Hour Hotspots (PNG) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=pu

blic:hotspots_24h&styles=&bbox=-2378164,-

707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png 

 

Example: Fire Danger (KMZ) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=Ge

tMap&layers=public:fdr&styles=&bbox=-2378164,-

https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetCapabilities
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetCapabilities
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=GetCapabilities
https://cwfis.cfs.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=GetCapabilities
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WCS&version=1.1.1&request=GetCapabilities
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fdr&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=kmz
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fdr&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=kmz
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707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=kmz 

  

Example: National Burned Area Composite (OpenLayers) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=Ge

tMap&layers=public:nbac&styles=&bbox=-2378164,-

707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=openlayers 

 

Example: Multiple Layers – Fire Weather Index + Last 24‑Hour Hotspots (PNG) 

Display multiple layers together by listing them in the layers= parameter, separated by commas. 

Layers render in order, with the last layer drawn on top. 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=Ge

tMap&layers=public:fwi,public:hotspots_24h&styles=&bbox=-2378164,-

707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png 

 

For full details on available parameters and formats, refer to the GeoServer WMS documentation: 

WMS Reference — GeoServer 2.28.0 User Manual 

8. WFS — GetFeature Requests 

Retrieve vector features with geometry and attributes. 

WFS format options: CSV, GeoJSON, GML, SHAPE‑ZIP, KML) 

Example: Hotspots (Last 24 Hours) — SHAPE‑ZIP 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/ows?service=WFS&version=2.0.0&request=Ge

tFeature&typeName=public:hotspots_24h&maxFeatures=100000&outputFormat=SHAPE-ZIP 

Example: Active Fires — CSV 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=Get

Feature&typeName=public:cwfif_national_activefires&maxFeatures=100000&outputFormat=CSV 

Customized Query using CQL_FILTER 

Custom queries can be built by first retrieving the feature schema with a DescribeFeatureType request and 

then applying a CQL_FILTER to filter features by attribute values. 

 

 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fdr&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=kmz
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:nbac&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=openlayers
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:nbac&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=openlayers
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:nbac&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=openlayers
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi,public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi,public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi,public:hotspots_24h&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://docs.geoserver.org/latest/en/user/services/wms/reference.html
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/ows?service=WFS&version=2.0.0&request=GetFeature&typeName=public:hotspots_24h&maxFeatures=100000&outputFormat=SHAPE-ZIP
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/ows?service=WFS&version=2.0.0&request=GetFeature&typeName=public:hotspots_24h&maxFeatures=100000&outputFormat=SHAPE-ZIP
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetFeature&typeName=public:cwfif_national_activefires&maxFeatures=100000&outputFormat=CSV
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=2.0.0&request=GetFeature&typeName=public:cwfif_national_activefires&maxFeatures=100000&outputFormat=CSV
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Example: Custom query – All Reported fires for year 2025 — CSV 

 

Use DescribeFeatureType to view feature attributes 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=1.1.0&request=Des

cribeFeatureType&typeName=public:cwfif_national_reportedfires 

 

Use CQL_FILTER to set desired filter 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs?service=WFS&version=2.0.0&request=Get

Feature&outputFormat=csv&typeName=public:cwfif_national_reportedfires&CQL_FILTER=fire_y

ear=2025 

  

For full details on available parameters and formats, refer to the GeoServer WFS documentation: 

WFS reference — GeoServer 2.28.0 User Manual 

9. WCS — GetCoverage Requests 

Retrieve raw raster data. 

WCS format options: GeoTIFF, GTopo30, ArcGrid, GZIP‑compressed ArcGrid, and other formats supported by 

the GeoServer instance. 

Example: FWI Coverage — GeoTIFF 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wcs?service=WCS&version=1.0.0&request=Ge

tCoverage&coverage=public:fwi&BBOX=-2378164,-

707617,3039835,3854382&WIDTH=2709&HEIGHT=2281&CRS=EPSG:3978&FORMAT=geotiff 

 

 Mandatory WCS Parameters 

• BBOX= 

• WIDTH= 

• HEIGHT= 

For full details on available parameters and formats, refer to the GeoServer WFS documentation: 

WCS reference — GeoServer 2.28.0 User Manual 

10. Accessing Date/Time‑Enabled Layers 

Some CWFIS 2.0 layers support a time dimension for historical or forecast data. 

 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=1.1.0&request=DescribeFeatureType&typeName=public:cwfif_national_reportedfires
https://geoserver.cwfif.nrcan.gc.ca/geoserver/ows?service=WFS&version=1.1.0&request=DescribeFeatureType&typeName=public:cwfif_national_reportedfires
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs?service=WFS&version=2.0.0&request=GetFeature&outputFormat=csv&typeName=public:cwfif_national_reportedfires&CQL_FILTER=fire_year=2025
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs?service=WFS&version=2.0.0&request=GetFeature&outputFormat=csv&typeName=public:cwfif_national_reportedfires&CQL_FILTER=fire_year=2025
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs?service=WFS&version=2.0.0&request=GetFeature&outputFormat=csv&typeName=public:cwfif_national_reportedfires&CQL_FILTER=fire_year=2025
https://docs.geoserver.org/latest/en/user/services/wfs/reference.html
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wcs?service=WCS&version=1.0.0&request=GetCoverage&coverage=public:fwi&BBOX=-2378164,-707617,3039835,3854382&WIDTH=2709&HEIGHT=2281&CRS=EPSG:3978&FORMAT=geotiff
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wcs?service=WCS&version=1.0.0&request=GetCoverage&coverage=public:fwi&BBOX=-2378164,-707617,3039835,3854382&WIDTH=2709&HEIGHT=2281&CRS=EPSG:3978&FORMAT=geotiff
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wcs?service=WCS&version=1.0.0&request=GetCoverage&coverage=public:fwi&BBOX=-2378164,-707617,3039835,3854382&WIDTH=2709&HEIGHT=2281&CRS=EPSG:3978&FORMAT=geotiff
https://docs.geoserver.org/latest/en/user/services/wcs/reference.html
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Date Format 

time=YYYY-MM-DD 

 

Timestamp Format (UTC) 

time=YYYY-MM-DDThh:mm:ss.SSSZ 

Examples 

...&layers=public:fwi&time=2025-09-05 

...&layers=public:hotspots_24h&time=2025-09-05 

 

Example: FWI for a specific date (PNG)  

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=pu
blic:fwi&time=2025-09-05&styles=&bbox=-2378164,-
707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png 

 

Example: Hotspots for a specific date (PNG) 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&la

yers=public:hotspots&time=2025-09-05&styles=&bbox=-2378164,-

707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png 

 

Not all services have time enabled; non‑time‑enabled layers will always return the current state. 

To identify which data services support date/time queries, refer to the GetCapabilities, the CWFIS Data 

Services Placemat, or the CWFIS Data Catalogue 

For more info regarding the time dimension see GeoServer docs. 

11. Connecting CWFIS Services in QGIS 

QGIS fully supports OGC‑compliant WMS, WFS, and WCS services. Once connected, layers can be viewed, styled, 

queried, and saved locally. 

Add a WMS Layer (Web Map Service) 

1. Open QGIS 

2. Go to Layer → Add Layer → Add WMS/WMTS Layer… 

3. Click New to create a new connection 

4. Enter a connection name (e.g., CWFIS WMS) 

5. Enter a CWFIS WMS endpoint, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wms? 

https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:fwi&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://cwfis.cfs.nrcan.gc.ca/geoserver/public/wms?service=WMS&version=1.3.0&request=GetMap&layers=public:hotspots&time=2025-09-05&styles=&bbox=-2378164,-707617,3039835,3854382&width=768&height=646&crs=EPSG:3978&format=image/png
https://prod-cwfis.azure.cloud.nrcan-rncan.gc.ca/en/data-catalog
https://docs.geoserver.org/main/en/user/services/wms/time.html
https://cwfis.cfs.nrcan.gc.ca/geoserver/wms
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Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wms? 

6. Click OK, then Connect 

7. A list of available WMS layers will appear 

8. Select a layer (e.g., public:fdr, public:hotspots_24h) 

9. Click Add Layer 

The layer will load as an image-only map (not raw data). 

Add a WFS Layer (Web Feature Service) 

1. Go to Layer → Add Layer → Add WFS Layer… 

2. Click New 

3. Provide a name (e.g., CWFIS WFS) 

4. Enter a WFS endpoint, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs? 

Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs? 

5. Click OK, then Connect 

6. Select a feature type (e.g., public:cwfif_national_activefires) 

7. Click Add Layer 

WFS layers provide full vector data with attributes, editable and exportable. 

Note: If the layer contains many features, consider setting a maximum feature limit, or using a CQL filter 

within WFS parameters to improve performance. 

Add a WCS Layer (Web Coverage Service) 

1. Go to Layer → Add Layer → Add WCS Layer… 

2. Click New 

3. Name the connection (e.g., CWFIS WCS) 

4. Enter a CWFIS WCS endpoint, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs? 

Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wcs? 

5. Click OK, then Connect 

6. Select a coverage (e.g., public:fwi) 

7. Click Add Layer 

The WCS layer loads as a raster grid, which can be analyzed and exported. 

https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
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Adding Time-Enabled Layers in QGIS 

If a CWFIS layer supports time (as seen in GetCapabilities): 

1. Load the WMS or WFS layer 

2. Right‑click the layer → Properties 

3. Choose the Temporal tab 

4. Enable “Temporal Layer” 

5. Set the time settings (e.g., Single fixed time, Dataset has time values) 

6. Enter or choose a date matching the time dimension 

This enables temporal playback and date‑specific map rendering. 

 

12. Connecting CWFIS Services in ArcGIS Pro 

ArcGIS Pro supports WMS, WFS, and WCS, although functionality varies slightly by service type. 

Add a WMS Layer (Web Map Service) 

1. Open ArcGIS Pro 

2. Go to Insert → Connections → New WMS Server 

3. Enter a WMS URL, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wms? 

Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wms? 

4. Click OK 

5. In the Catalog pane, expand Servers 

6. Expand the new WMS connection 

7. Drag any WMS layer into your map 

WMS layers render as images only. 

Add a WFS Layer (Web Feature Service) 

1. Go to Insert → Connections → New WFS Server 

2. Enter a CWFIS WFS endpoint, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs? 

Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs? 

3. Click OK 

4. Locate the WFS connection in the Catalog → Servers 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wms
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
https://cwfis.cfs.nrcan.gc.ca/geoserver/wfs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
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5. Open the list of feature types 

6. Drag a layer (e.g., public:hotspots_24h) into the map 

Notes for ArcGIS Pro users: 

• Some complex CQL filters may not be supported natively 

• WFS performance varies with very large datasets 

• If necessary, set feature limits in the WFS connection properties 

Add a WCS Layer (Web Coverage Service) 

1. Go to Insert → Connections → New WCS Server 

2. Enter a WCS endpoint, for example: 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs? 

Or https://geoserver.cwfif.nrcan.gc.ca/geoserver/wcs? 

3. Click OK 

4. In Catalog → Servers, expand the new WCS connection 

5. Drag desired coverage (e.g., public:fwi) into your map 

ArcGIS Pro will load the raster as a regular analysis‑ready dataset. 

Time-Enabled Layers in ArcGIS Pro 

For layers with a time= dimension: 

1. Add the layer 

2. Right‑click → Properties 

3. Go to the Time tab 

4. Set:  

a. Layer Time → Each feature has a single time field, or 

b. WMS Time Extent (ArcGIS reads the time dimension if available) 

5. Select the desired date/time 

6. Enable the Time Slider 

Tips for Successful Connections 

• Ensure your network allows external traffic to GeoServer endpoints 

• If performance is slow, limit WFS features or apply filters 

• Use EPSG:3978 for Canadian Atlas Lambert (CWFIS native CRS) 

• For web applications, prefer WMS for performance and WFS/WCS for analysis 

https://cwfis.cfs.nrcan.gc.ca/geoserver/wcs
https://geoserver.cwfif.nrcan.gc.ca/geoserver/wfs
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13. Additional External Resources/References 

• Advancing Open Geospatial Standards for Interoperability | OGC - Overview of OGC’s work on open 

geospatial standards. 

• WMS reference — GeoServer 2.28.0 User Manual  (English only) - Technical documentation for 

GeoServer's Web Map Service (WMS) implementation. 

• WFS reference — GeoServer 2.28.0 User Manual (English only) - Technical documentation for 

GeoServer's Web Feature Service (WFS) implementation. 

• WCS reference — GeoServer 2.28.0 User Manual (English only) - Technical documentation for 

GeoServer's Web Coverage Service (WCS) implementation. 

14. Glossary of Terms 

ArcGrid 

A raster data format used in GIS applications, often supported by WCS for gridded datasets. 

Bounding Box (BBOX) 

A spatial extent defined by minimum and maximum X/Y coordinates, used to request a map or data subset 

from OGC services. 

CQL Filter (Common Query Language Filter) 

A GeoServer query syntax used to filter features based on attribute values when requesting data from a WFS 

service. 

Coverage (Raster Coverage) 

A raster dataset served through a Web Coverage Service (WCS), representing gridded values such as fire 

weather or burned area. 

CSV (Comma‑Separated Values) 

A simple tabular data format often used for hotspots, fire observations, and attribute-only outputs. 

DescribeFeatureType 

A WFS request that returns the schema (attributes, data types) of a vector dataset. 

EPSG Code 

A standardized identifier for a coordinate reference system. CWFIS commonly uses EPSG:3978 (Canada Atlas 

Lambert). 

https://www.ogc.org/
https://docs.geoserver.org/latest/en/user/services/wms/reference.html
https://docs.geoserver.org/latest/en/user/services/wfs/reference.html
https://docs.geoserver.org/latest/en/user/services/wcs/reference.html


 

 13 

UNCLASSIFIED - NON CLASSIFIÉ 

Feature (Vector Feature) 

An individual vector object (point, line, or polygon) representing geographic data such as a hotspot or fire 

perimeter. 

GeoJSON 

A widely used JSON‑based format for encoding geographic vector features. 

GeoServer 

An open-source geospatial server used by CWFIS to publish WMS, WFS, and WCS data services. 

GeoTIFF 

A georeferenced raster format commonly used for WCS outputs and downloadable grid data. 

GetCapabilities 

An OGC request that returns metadata about all available layers and operations within a WMS, WFS, or WCS 

service. 

GetCoverage 

A WCS request that retrieves raster data for a specified coverage layer and spatial extent. 

GetFeature 

A WFS request that retrieves vector features and their attributes. 

GetMap 

A WMS request used to retrieve rendered map images for one or more layers. 

GML (Geography Markup Language) 

XML‑based format for representing geographic features, commonly supported through WFS. 

KMZ (Keyhole Markup Language – Zipped) 

A compressed KML package commonly used in Google Earth and supported by WMS output. 

OGC (Open Geospatial Consortium) 

The organization that develops open standards for spatial data interoperability, including WMS, WFS, and 

WCS. 

OWS (OGC Web Services) 

A unified request endpoint in GeoServer that supports WMS, WFS, and WCS operations. 

Raster 

A gridded dataset composed of pixels, used to represent continuous spatial information such as fire danger 

or weather indices. 
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Shapefile (SHP / SHAPE‑ZIP) 

A standard vector dataset format packaged as a ZIP file for distribution through WFS or downloads. 

Static Map 

A pre‑rendered map image for reference, typically provided as PNG or JPEG. 

Time‑Enabled Layer 

A dataset that supports querying by date or timestamp (e.g., daily FWI, hotspots for a specific day). 

Vector 

A data structure representing geographic features using points, lines, and polygons. 

Web Coverage Service (WCS) 

An OGC service for accessing raster data coverages such as FWI grids or NBAC layers. 

Web Feature Service (WFS) 

An OGC service for accessing vector data with attribute information. 

Web Map Service (WMS) 

An OGC service that delivers rendered map images for visualization. 

 

If you have questions or comments, please contact cwfissa-csscifv@nrcan-rncan.gc.ca  

Note: Portions of this resource were developed with assistance from AI tools and have been reviewed for 

accuracy and clarity. 
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